Java Maven Error 〜-source 7以降を使用してください〜

Mavenの実行時エラーに以下のような文言が出た時の対処

(リテラル内のアンダースコアを使用可能にするには、-source 7以降を使用してください)
(ラムダ式を使用可能にするには、-source 8以上を使用してください)
(try-with-resourceを使用可能にするには、-source 7以降を使用してください)

これは単純にコンパイラーのバージョンが古いのでバージョンをあげてください。。。と言うことですが、「Eclipseの設定ではJava8使ってるのに?」とか不明点があり少しハマりました。

Mavenで使用するデフォルトのコンパイラー(JDK)のバージョンが古いのが原因でした。

なので以下のようにプロパティを追加してやればOK